Results 1 to 2 of 2

Thread: "Modified" icon at root level

  1. #1

    "Modified" icon at root level

    I'm a Subversion newbie, and am currently seeing an issue where I have the red exclimation point icon on the highest level folder, but all of the folders below it are green. Is there any way to get the root level folder back to green?

  2. #2
    Junior Member
    Join Date
    Oct 2014
    Location
    Austin, Texas
    Posts
    2
    I got into this state by attempting to SVN Rename a file in my working copy that I had open in another program. The error message indicated that the SVN Rename hadn't worked, so I thought that meant it had no effect. But the directories above got the red exclamation point.

    If I tried to SVN Commit at the directory level to complete the Rename, or SVN Revert at the directory level to back out the Rename, it complained that the new filename was missing. That indicated that the metadata had been changed when I tried to Rename, even though the Rename failed. Eventually I found that right-clicking on the new filename in the error message brought up a little four-item menu. Clicking on the Revert from that menu produced a message claiming there was nothing to revert (since the files all agree with the repository?), but the red exclamation point on the directories had changed to a green check.
    Last edited by JohnTate; 10-28-2014 at 09:07 AM. Reason: New information from further experiments

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •