Results 1 to 5 of 5

Thread: TortoiseSVN icons not updating after Commit

  1. #1

    TortoiseSVN icons not updating after Commit

    This problem is reproducable every time:

    Software:
    TortoiseSVN version: 1.7.6, Build 22632, 32-bit
    Subversion 1.7.4

    How to create the problem:
    1) Checkout a repository, or get the latest updates from a previously-copied repository. At this point, all files are current (everything has the green checkmark icon).
    2) Make a change to a local file. That file icon will then change to "Modified" (the red icon).
    3) Commit the change.

    ...and after the Commit successfully finishes, the icon still stays as the red exclamation-point "Modified" icon. The icon status doesn't change, even after Committing the change back to the repository.

    This seems to be permanent - the icon will remain this way for days. F5 does nothing. The one fix is that if I go to the parent folder and do a "Clean Up" with "Refresh Shell Overlays", it will fix the issue. But this is not a solution, since this problem happens every time I Commit a file!

    Can anyone assist?

    Thanks,

    Andy
    Last edited by abkaiser; 04-26-2012 at 06:21 AM.

  2. #2
    Just wanted to bump this thread, and also say I'm willing to pay for someone's expertise: If you can permanently fix this problem for me, I'll send you $25 via PayPal.

  3. #3
    I'm closing my offer. I found a solution acceptable to the users.

    The short story for those interested:

    Icon Overlays and the "SVN Commit" Function

    In some cases, the Tortoise icons will not update. For example, the icon will remain in "Modified" status, even though changes were just committed. The icon update job time is a function of the size of the folders being processed. If icon overlays update incorrectly or slowly, consider:

    If you "Commit" your local copy at the root of the repository (Desktop -> Repository1), this may take a long time to show updated icons. Instead, run the "Commit" at the subfolder level nearest to the updated files (like Desktop -> Respository1-> Folder 1 -> Folder 2 -> Folder 3, where Folder 3 is the parent of the changed files. In this case, you'd want to "Commit" only Folder 3.)

    If Icons aren't updating at all, something went wrong with the automatic update function. If this happens on a regular basis, something is wrong. If this happens only periodically, you can fix this by right-clicking the root of the Repository, and click Tortoise SVN -> Clean Up -> Refresh Shell Overlays.

  4. #4
    I always Commit at the lowest folder holding the files and I experience this unfortunate issue constantly.

    Refreshing or restarting the explorer (I use Free Commander) window does not help.

    If I wait some ridiculous amount of time (say an hour or so) and come back (watched pot...) the icons are miraculously correct (red exclamation finally missing).

  5. #5
    Yeah may be as abkaiser say "If you "Commit" your local copy at the root of the repository (Desktop -> Repository1), this may take a long time to show updated icons". And i find out that if you take update command immediate after commit command , the icons will be correct ( become green). There fore, I am finding way to config Commit- Update command in TortoseSVN . I you have any idea please tell me, thank

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •