Page 1 of 2 12 LastLast
Results 1 to 20 of 22

Thread: Problem connecting to UberAPPS

  1. #1

    Problem connecting to UberAPPS

    Somehow Jenkins won't download from the UberAPPS. Everything went fine and I can see the Apps and filled the registration, but after I completed the registration, I go to ManageAPPS and try to download Jenkins, it just can't connect.
    (We're unable to connect to the UberAPPS page)

    It's definately not a firewall issue, because I did a wget to https://ump.ubersvn.com:7487/ump/ (found in another forum) and that worked fine.
    I even disabled the firewall completely and still couldn't connect.

    A reboot of the server also didn't gave any result.

    This is a piece of the logging:
    INFO - Update mirror is: update.nl.eu.ubersvn.com
    INFO - Found 0 available updates
    INFO - Found 0 eligible updates
    ERROR - Unable to download package for:Jenkins
    INFO - Downloading images for page.
    ....
    INFO - Downloading page from the UMP
    ERROR - Object not found response from UMP

    uberSVN version: Core 12.03.9420-2
    OS: CentOS 5.8

    I'm at a loss.....
    Last edited by rvarkevisser; 04-09-2012 at 02:20 PM.

  2. #2
    Administrator Site ModeratorSite Admin
    Join Date
    May 2011
    Posts
    312
    Hi rvarkevisser,

    Sorry to hear you're having this problem. I'm taking a look at it now and will update you on my findings.


    Thanks

    Wayne

  3. #3
    Thank you wmellors for looking in to this. I will keep watching this thread for an update.

  4. #4
    Administrator Site ModeratorSite Admin
    Join Date
    May 2011
    Posts
    312
    Hi again,

    I've just completed multiple uberAPPS Jenkins installs, without any problems. I tested this on uberSVN 12.3 via..

    Windows Server 2008
    Scientific Linux 6 32bit and
    CentOS 5 64bit

    I've spoken with the developers and some questions they have are..

    1) Is the user you're using an uberSVN Admin and an uberAPPS User?
    2) Are you using one user account to 'buy' Jenkins and then subsequently download it?

  5. #5
    The user is the Admin user. I also tried it with a new user, upgraded as an admin user, but still no luck.
    I''m not sure about question nr.2 I think i'm using one user account, but I had to register for a free serial key and within UberAPP I got a new registration form, which I had to fill in. I used the same information though.

    Any tips what I can try?

  6. #6
    Ps. Can it be because I didn't fill in a payment methode? I''m not sure what happens when I add my creditcard information.

  7. #7
    Administrator Site ModeratorSite Admin
    Join Date
    May 2011
    Posts
    312
    Ok, so the uberSVN user in question needs to be an uberAPPS User, as well as an uberSVN Admin user if you want the same account to do all the work. The reason being that the uberAPPS User can buy/access apps but then the uberSVN Admin needs to download/configure them for usage. Can you confirm that the user account in question has both those preferences enabled?

    It definitely won't be because you didn't add a payment method, as Jenkins is free so there's no validation happening there. All you need to have done is registered the user, which it sounds like you've done.

  8. #8

    The admin account and the user account have the following 4 permissions
    System admin
    Team admin
    Repository admin
    UberApp user

    I think i will remove ubersvn and try to reinstall it. There's clearly no simple answer to this problem. Luckily i use vmware, so i will revert back to a previous snapshot and try again.

  9. #9
    Ps. If i do this, how can I use the same registration information without any conflict?

  10. #10
    Administrator Site Admin ianwild's Avatar
    Join Date
    Jul 2010
    Location
    Sheffield, UK.
    Posts
    257
    Hmmm, thanks for your help with this. You are able to use the same uberSVN registration key for more than one instance so this shouldn't pose any difficulties.

    Best Wishes,

    Ian
    Ian Wild
    uberSVN Product Manager
    WANDISCO, Inc.

    Free Online Subversion Training
    http://hub.wandisco.com/eTraining

    Join us on facebook!
    http://hub.wandisco.com/eFacebook

  11. #11
    Well this time I did a clean install of CentOS 5.8 and 6.2 and both gave the same problem. I used the minimal install of 6.2 and installed some basic packages. I keep getting the same error even with a flushed iptables. The store shows perfectly, but jenkins just won't download.

    I see in the logging it's connecting to a dutch repository (update.nl.eu.ubersvn.com). Could that be the problem?

    Edit: I put the dns name update.nl.eu.ubersvn.com in the hosts file with the ip of update.ubersvn.com. Same problem, same error.
    Last edited by rvarkevisser; 04-11-2012 at 11:02 AM.

  12. #12
    Administrator Site ModeratorSite Admin
    Join Date
    May 2011
    Posts
    312
    Hi again,

    One more question I have is, did you install uberSVN 12.3 afresh or did you update from a prior version? The reason I ask is that the update server should serve both Jenkins packages and Core uberSVN update packages, so if the former doesn't work, then I don't understand how the latter could work.

    I've verified that the Jenkins update package in question is actually on update.nl.eu.ubersvn.com.


    Thanks

    Wayne
    Last edited by wmellors; 04-12-2012 at 02:31 AM.

  13. #13
    I did a clean install of ubersvn BETA 12.03 for Linux on CentOS 5.8 (clean) and 6.2 (clean)
    This is exactly what i did.

    vi /etc/selinux/config

    SELINUX=disabled

    yum update

    yum install nano sudo wget ntp crontabs make gcc gcc-c++ perl tar flex net-snmp net-snmp-utils net-snmp-perl krb5-libs krb5-devel pam-devel libc-client libc-client-devel libgcrypt-devel libxslt-devel libtool httpd php-cli mod_ssl

    
/sbin/chkconfig anacron off

    /sbin/chkconfig bluetooth off

    /sbin/chkconfig cups off

    /sbin/chkconfig gpm off

    /sbin/chkconfig ip6tables off
    
/sbin/chkconfig isdn off

    /sbin/chkconfig mcstrans off

    /sbin/chkconfig mdmonitor off

    /sbin/chkconfig mdmpd off

    /sbin/chkconfig pcscd off

    /sbin/chkconfig restorecond off

    /sbin/chkconfig snmpd on
    
/sbin/chkconfig wpa_supplicant off
    
/sbin/chkconfig xfs off

    yum remove wpa_supplicant mdadm isdn4k-utils.i386 cups.i386 pcmciautils.i386

    nano /root/.bash_profile
PATH=$PATH:$HOME/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/bin:/usr/local/sbin

    export PATH

    cd /usr/local/src
    wget http://www.rfxn.com/downloads/apf-current.tar.gz
    tar -zxvf apf-current.tar.gz
    cd apf-<version>
    ./install.sh


    nano /etc/apf/conf.apf
    
DEVEL_MODE=”0”
    SET_FASTLOAD=”1”
    IG_TCP_CPORTS="22,25,80,443,9880,9890,9900"

    LOG_DROP="1"

    (IG_TCP is incomming. EG_TCP is outgoing and is ANY)
    /etc/init.d/apf/restart

    Reboot server!

    cd /usr/local/src

    wget http://download.ubersvn.com/uberSVN-32-1203_beta.sh
    
chmod +x uberSVN-32-1203_beta.sh
    ./uberSVN-32-1203_beta.sh
    
y y n y

    http://<IP>:9890/ubersvn
    Filled in the key and registration
    Went to uberAPPS
    Filled in the registration and tried to download jenkins
    !ERROR
    Last edited by rvarkevisser; 04-12-2012 at 04:53 AM.

  14. #14
    Administrator Site ModeratorSite Admin
    Join Date
    May 2011
    Posts
    312
    Thanks for the details. So it is a fresh deployment of 12.3.

    Ok, as a further test to this could you perform an update check and download the new SVN 1.6.18 binaries (you don't then need to install, if you don't want)? If that works, that will tell us that your connection to the update server is working as expected and we can scratch that off the list. If it doesn't work, it may point to a connection fault between your uberSVN box and our update server.

  15. #15
    Senior Member Site ModeratorSite Admin
    Join Date
    Mar 2011
    Location
    Chesterfield, UK
    Posts
    771
    Excellent details rvarkevisser, thanks.

    One thing to bear in mind is that uberSVN makes use of cron, so this line might cause you trouble:

    /sbin/chkconfig anacron off

    Mat Booth
    Software Engineer
    WANdisco, Inc.

    I joined the blog-o-web-o-sphere! Linux and Coding Blog

    How To Ask Smart Questions

  16. #16
    mbooth, thank you for the help, but turning anacron on/off does not solve the problem though. But I will leave it on.
    I once again did a reinstall of CentOS 6.2, with anacron on this time (to make sure) and tailed the logging during first startup. No errors and everything is fine, except for a few warning errors:
    WARN - Could not find a specific ehcache configuration for cache named
    INFO - New update(s) found: 2.4.7 [http://www.terracotta.org/confluence...ache+Core+2.4]. Please check http://ehcache.org for the latest version.

    I'm not sure how to update de SVN from 1.6.17 to .18, because when I click on "Check for Updates" it says, no updates available.
    subversion16 Subversion 1.6 Binaries Core 1.6.17-6

    Here's the logging after 2 tries:
    [12 Apr 2012 23:56:44] INFO - Getting updates from: http://update.ubersvn.com/
    [12 Apr 2012 23:56:44] INFO - Update mirror is: update.nl.eu.ubersvn.com
    [12 Apr 2012 23:56:44] INFO - Found 0 available updates
    [12 Apr 2012 23:56:44] INFO - Found 0 eligible updates
    [12 Apr 2012 23:56:56] INFO - Getting updates from: http://update.ubersvn.com/
    [12 Apr 2012 23:56:57] INFO - Update mirror is: update.nl.eu.ubersvn.com
    [12 Apr 2012 23:56:57] INFO - Found 0 available updates
    [12 Apr 2012 23:56:57] INFO - Found 0 eligible updates

    OS: CentOS 6.2

    I did however try the newest version 1.7.4, using the SVN switch. Still can't download Jenkins or updates.
    Last edited by rvarkevisser; 04-12-2012 at 02:20 PM.

  17. #17
    Senior Member Site ModeratorSite Admin
    Join Date
    Mar 2011
    Location
    Chesterfield, UK
    Posts
    771
    Hmmm, the most obvious case when you don't get updates is when there is a type-o in your registration key. Can you please confirm the registration key that you are using when you install uberSVN? Send it to me either in a private message or directly to mat.booth@wandisco.com to keep it private if you wish to. I will look you up in our database and try to figure out where it's going wrong.
    Mat Booth
    Software Engineer
    WANdisco, Inc.

    I joined the blog-o-web-o-sphere! Linux and Coding Blog

    How To Ask Smart Questions

  18. #18
    Senior Member Site ModeratorSite Admin
    Join Date
    Mar 2011
    Location
    Chesterfield, UK
    Posts
    771
    Hi,

    Would you able to try again? We found and corrected a database problem that we suspect was preventing you from receiving updates.
    Mat Booth
    Software Engineer
    WANdisco, Inc.

    I joined the blog-o-web-o-sphere! Linux and Coding Blog

    How To Ask Smart Questions

  19. #19
    Administrator Site ModeratorSite Admin
    Join Date
    May 2011
    Posts
    312
    Quote Originally Posted by rvarkevisser View Post
    mbooth, thank you for the help, but turning anacron on/off does not solve the problem though. But I will leave it on.
    I once again did a reinstall of CentOS 6.2, with anacron on this time (to make sure) and tailed the logging during first startup. No errors and everything is fine, except for a few warning errors:
    WARN - Could not find a specific ehcache configuration for cache named
    INFO - New update(s) found: 2.4.7 [http://www.terracotta.org/confluence...ache+Core+2.4]. Please check http://ehcache.org for the latest version.

    I'm not sure how to update de SVN from 1.6.17 to .18, because when I click on "Check for Updates" it says, no updates available.
    subversion16 Subversion 1.6 Binaries Core 1.6.17-6

    Here's the logging after 2 tries:
    [12 Apr 2012 23:56:44] INFO - Getting updates from: http://update.ubersvn.com/
    [12 Apr 2012 23:56:44] INFO - Update mirror is: update.nl.eu.ubersvn.com
    [12 Apr 2012 23:56:44] INFO - Found 0 available updates
    [12 Apr 2012 23:56:44] INFO - Found 0 eligible updates
    [12 Apr 2012 23:56:56] INFO - Getting updates from: http://update.ubersvn.com/
    [12 Apr 2012 23:56:57] INFO - Update mirror is: update.nl.eu.ubersvn.com
    [12 Apr 2012 23:56:57] INFO - Found 0 available updates
    [12 Apr 2012 23:56:57] INFO - Found 0 eligible updates

    OS: CentOS 6.2

    I did however try the newest version 1.7.4, using the SVN switch. Still can't download Jenkins or updates.
    OK, so on the surface that appears again to be an inability for your system to see our update server. If you can PM Mat with your registration key we can eliminate that as a possible reason why you can't perform any updates but if that does come back as legitimate then, IMHO I think we need to be looking more closely at the network side of things.

    Are you in an office environment ringed with firewalls, as well as firewalls running on the uberSVN box itself? I understand you shut off the latter but if the former is still in effect, it could be causing the block.

  20. #20
    Wmellors, i already had contact with matt, but thank you.

    I think it worked! It's finding updates and i just installed Jenkins! Perfect and I want to thank you for all the help. I'm still gonna try clean install, just to make sure. I've been playing and installing more modules during this day, so I will revert back once more and try it again.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •