Page 2 of 2 FirstFirst 12
Results 21 to 32 of 32

Thread: How to import source into repository

  1. #21
    John,

    Thank you for the documentation. However, I tried uninstall and reinstall while waiting for your help and created another problem for myself. I can not try the instucations in your documentation untill I resolve the problem. I have started another thread for my current problem yesterday but have not get any help on that yet.

    Let me copy the contents of the other thread below to see if you can help me out.
    Uninstall then reinstall uberSVN, http hangs

    Hello,

    I tried to uninstall uberSVN by "rm -rf /opt/ubersvn". Then I was able to not get the warning, there is an existing subversion, by "rm /var/lock/ubersvn_install". When I try to run "http://myipaddress:9890/ubersvn" the browser is wating forever.

    I believe the problem is because I did not stop the httpd service when uninstall and reinstall. Am I correct? If yes, could anybody tell me how to stop the httpd service? I tried "/sbin/service httpd stop", the system said there was no such a service. I also tried "apachectl stop", my machine did not recognize apachectl command. Thank you for any help in advance.

    Nelson

  2. #22
    Hi Nelson,

    Try this as root :
    Code:
    ps -ef | grep /ubersvn/
    this should give you a list of processes that ubersvn is running.
    You can now kill those processes via a kill pid -9 call.

    You would then need to try the following to start the ubersvn servers:

    Code:
    cd /opt/ubersvn/bin
    ./svnservercontrol start
    ./ubersvncontrol start
    This should get you back up and running again.

    If you need any further assistance then please let me know.
    John Chambers

    Software Engineer,
    uberSVN Team.
    WANdisco Inc.

  3. #23
    John,

    I carried out your insturctions and got "prototype - Revision 0:/" on the browser when I access "httP://myipaddrort#:myrepository" URL. I must have done something incorrectly. Do you have a clue by this little information? I have no idea what is happening. Thank you.

    Nelson

  4. #24
    Administrator Site Admin ianwild's Avatar
    Join Date
    Jul 2010
    Location
    Sheffield, UK.
    Posts
    257
    Hi Nelson,

    That doesn't look like a valid URL. Are you doing http://my_iport/reponame ?- Can you post a screenshot of this? What is the name of your repository (is it protoype?).

    Ian
    Ian Wild
    uberSVN Product Manager
    WANDISCO, Inc.

    Free Online Subversion Training
    http://hub.wandisco.com/eTraining

    Join us on facebook!
    http://hub.wandisco.com/eFacebook

  5. #25
    Administrator Site Admin ianwild's Avatar
    Join Date
    Jul 2010
    Location
    Sheffield, UK.
    Posts
    257
    Hi Nelson,

    That doesn't look like a valid URL. Are you doing http://my_iport/reponame ?- Can you post a screenshot of this? What is the name of your repository (is it protoype?).

    Ian
    Ian Wild
    uberSVN Product Manager
    WANDISCO, Inc.

    Free Online Subversion Training
    http://hub.wandisco.com/eTraining

    Join us on facebook!
    http://hub.wandisco.com/eFacebook

  6. #26
    Nelson,

    It looks to me like you have configured a new repository called prototype and have not yet imported anything. If you access http://server_ip:9880/repoName (9880 is the default apache port) you should be prompted for your user credentials and then shown the top level of your repository. In this case because the repository is empty and at revision 0 that is all you will see.

    I hope that this helps. If not please let me know what you where expecting to see.
    John Chambers

    Software Engineer,
    uberSVN Team.
    WANdisco Inc.

  7. #27
    John,

    Your correct. I was too excited and forgot to import my source. Will try to see if I can use Eclipse plugin to access my repository and let you know. Thank you and Ian very much.

    Nelson

  8. #28
    John,

    I am very close and I believe I can demo it this afternoon. However, the last step of using subclipse to checkout from my repository is having problem. Please help me out on this one last step. I don't know how to attach the screenshot. So I am going to send it by responding to the system generated e-mail. The error message is: Failed to load JavaHL Library.
    These are the errors that were encountered:
    no libsvnjavahl-1 in java.library.path
    no svnjavahl-1 in java.library.path
    no svnjavahl in java.library.path
    java.library.path = /usr/java/jdk1.6.0_18/jre/lib/i386/client:/usr/java/jdk1.6.0_18/jre/lib/i386::/usr/java/packages/lib/i386:/lib:/usr/lib

    Nelson

  9. #29
    Administrator Site Admin ianwild's Avatar
    Join Date
    Jul 2010
    Location
    Sheffield, UK.
    Posts
    257
    Hi Nelson,

    This is an Eclipse question rather than an uberSVN one and I'm afraid I don't know Eclipse (I am but a mere product manager). I'm sure though that someone here can advise on this. It may just be that your own machine needs a copy of Java or you have to update your JAVA_HOME setting to tell Eclipse where Java is installed.

    Attached below is the screenshot you emailed to me.

    subclipse-uberSVN-error.jpg

    Ian
    Ian Wild
    uberSVN Product Manager
    WANDISCO, Inc.

    Free Online Subversion Training
    http://hub.wandisco.com/eTraining

    Join us on facebook!
    http://hub.wandisco.com/eFacebook

  10. #30
    Nelson,

    Here is a link to the relevant part of the Subclipse wiki that details javahl set up. Your install of uberSVN includes the required so file in /opt/ubersvn/lib so that is the path you should use when setting -Djava.library.path.

    If you need any further assistance then please let me know.
    John Chambers

    Software Engineer,
    uberSVN Team.
    WANdisco Inc.

  11. #31
    John and Ian,

    I am up and running. My boss likes uberSVN too now. I am using Intellij to check out and commit right now. I may give Eclipse a try again when I have time. Really appreciate all your help. Your support is excellent.

    Nelson

  12. #32
    Administrator Site Admin ianwild's Avatar
    Join Date
    Jul 2010
    Location
    Sheffield, UK.
    Posts
    257
    That is great news Nelson, best of luck with everything. Please do let us know how you get on and of course you know where we are if you need anything else

    Best Wishes,

    Ian
    Ian Wild
    uberSVN Product Manager
    WANDISCO, Inc.

    Free Online Subversion Training
    http://hub.wandisco.com/eTraining

    Join us on facebook!
    http://hub.wandisco.com/eFacebook

Similar Threads

  1. Import an open-source project to local with option to update
    By yoavhacohen in forum Version Control Practices
    Replies: 2
    Last Post: 01-17-2009, 04:11 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •