No announcement yet.

Problems committing (405 Method not allowed)

  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems committing (405 Method not allowed)

    Hi all,

    I am still quite new to SVN and I am having problems committing certain folders within my repository. I am able to commit some folders - others not.

    The error i am getting is:

    "Error: Server sent unexpected return value (405 Method Not Allowed) in response to Error: MKCOL request for '/71/!svn/wrk/9342507e-c9b8-724a-9acc-010f3b4db6b1/components/......."

    I have been searching around for a while and haven't been able to find a solution as yet...
    Any help would be much appreciated!!
    Knowledge is Power

  • #2
    I have the same problem.. with both the client and server at version 1.5.1.
    I've been using svn for many years, and I have never seen, nor have an idea how to resolve the issue. The closest I've found is this thread on the subversion dev mailing list where someone posted a detailed description of the error. There was a reply with a suggested solution involving recompiling the server, but the proposed solution didn't work, and the problem remains unresolved. If anyone has any suggestions, I'm all ears !


    • #3
      I'm not sure how the problem came about but i managed to fix the problem by using the import command.

      Once selecting the import command (which for some reason does not always seem to be available) but according to svn help is structured as:
      TortoiseSVN -> Import
      which then brings up a dialog box where you are able to select a repository, once selecting my repository in question, i was able to browse the folders within the repository. I then deleted the folder that was giving me the issue. After deleteting the folder i re-added my folder which was giving me the problem (which i backed up and deleted all .svn folders) and recommitted.

      This resolved the problem and i was able to fully commit again.

      Knowledge is Power


      • #4
        Originally posted by Samurai9 View Post
        I'm not sure how the problem came about but i managed to fix the problem by using the import command.
        I dont see import command. where do you see that?


        • #5
          Solution that worked for me..

          TortoiseSVN -> Repo-browser..
          than select the directory and checkout on rightclick of that directory


          • #6
            It worked for me