Announcement

Collapse
No announcement yet.

Server sent unexpected return value (405 Method Not Allowed)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Server sent unexpected return value (405 Method Not Allowed)

    this is set up on a VMWare on a windows system

    when i try to view the repobrowser or add a project to svn i get this

    Server sent unexpected return value (405 Method Not Allowed) in respons e to PROPFIND request for '/svn'

    http://somewhere-maybenowhere:8080/svn

    any ideas?

  • #2
    Can't do much w/o you posting the Location block from your Apache config which points at your repository.
    I am neither an employee nor customer of WANDisco.

    Comment


    • #3
      Originally posted by andyl
      Can't do much w/o you posting the Location block from your Apache config which points at your repository.
      Where would i locate this config file? collabnet subversion was run on the server designated for svn

      Comment


      • #4
        It's called httpd.conf
        I am neither an employee nor customer of WANDisco.

        Comment


        • #5
          Originally posted by andyl
          It's called httpd.conf
          file located

          <Location /svn/>
          DAV svn

          SVNListParentPath on
          SVNParentPath "C:/Repositories/"
          SVNIndexXSLT "/svnindex.xsl"
          SVNPathAuthz on

          AuthName "Subversion Repositories"
          AuthType Basic
          AuthBasicProvider file
          AuthUserFile "C:/Repositories//htpasswd"
          AuthzSVNAccessFile "C:/Repositories//authz"

          require valid-user
          </Location>

          Comment


          • #6
            Code:
            <Location /svn/>
            Try
            Code:
            <Location /svn>
            I am neither an employee nor customer of WANDisco.

            Comment


            • #7
              Originally posted by andyl
              Code:
              <Location /svn/>
              Try
              Code:
              <Location /svn>
              Trying that. Do i have to recyle any services?

              Comment


              • #8
                Originally posted by jsheth
                Originally posted by andyl
                Code:
                <Location /svn/>
                Try
                Code:
                <Location /svn>
                Trying that. Do i have to recyle any services?

                Now i get 403 Forbidden in response to OPTIONS

                Comment


                • #9
                  on a side note i am using VisualSVN

                  http://www.visualsvn.com/support/topic/00014/

                  Comment


                  • #10
                    Hi jsheth

                    I'm not sure I understand. Are you saying that the problem was that you didn't realise that most clients (web browsers being the exception, if you're using Apache) won't list repositories? (FWIW, this issue has been discussed ad nauseum on this forum over the past couple of weeks).

                    Your first post suggested that the problem was when you tried to add a "project" to a repository.

                    Is this now "solved", or do you still have a problem?

                    Cheers
                    John[/i]
                    John Niven

                    Comment


                    • #11
                      SOLVED:;Solution in this message

                      Originally posted by JNiven
                      Hi jsheth

                      I'm not sure I understand. Are you saying that the problem was that you didn't realise that most clients (web browsers being the exception, if you're using Apache) won't list repositories? (FWIW, this issue has been discussed ad nauseum on this forum over the past couple of weeks).

                      Your first post suggested that the problem was when you tried to add a "project" to a repository.

                      Is this now "solved", or do you still have a problem?

                      Cheers
                      John[/i]
                      SOLVED:
                      Removed everything which was instaalled from CollabNet and VisualSVN due to this
                      http://www.visualsvn.com/support/topic/00014/

                      and it not working with TortoiseSVN repobrowser

                      So i got the binaries from tigris and installed as per instructions found online. Ran it as a service using

                      http://svn.collab.net/repos/svn/trun...ws-service.txt

                      Everything works as expected.

                      Comment


                      • #12
                        I got the same error message with VisualSVN Server, but the problem was not the Apache config.
                        I tried to create a Tag, but the server sent me an error (Server sent unexpected return value (405 Method Not Allowed)).


                        The problem was the URL:
                        I tried: http://<server>/svn/Test/tags/<tagname>

                        But the actual repository was named test (lowercase), in stead of Test.

                        So using the following URL solved my problem: http://<server>/svn/test/tags/<tagname>



                        Just in case anyone else encounters this problem, check case sensitivity too

                        Comment

                        Working...
                        X